Dyld: Library not loaded error on macOS (OpenSSL missing)


#1

If you are trying to set up TagUI on MacOS, and you encounter the following error:

dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
Referenced from: /Volumes/tagui/src/phantomjs/bin/phantomjs
Reason: image not found

It’s because the openssl library is not installed on your machine.

To resolve this:

  1. Install Homebrew on your Mac if you haven’t

  2. Install openssl
    brew install --upgrade openssl

That’s it! TagUI should now be able to run on your Mac!